Monthly Archives: September 2013

Servicing the new ReVox PR99 with new VU lamps and roller bearing

Hello all,

Today I have been busy servicing my new ReVox PR99. This deck is built like a tank (to use an too often heard metaphor regarding tape decks) and it is working well. It is a 2 track deck which is designed for heavy use, like in studios and broadcast facilities. It is world famous for that.

But when I received it – actually I fetched it from way across Holland – I immediately noticed three small things wrong with it:

  • the VU meter lights were not working
  • the left tape guide roller bearing was making noise
  • and the infrared tape sensor incorrectly identified tape as being leader tape and switches off. This happens with some tapes that are apparently too thin 🙂

So I ordered and received 2 spare bulbs (from a webshop) and one new roller bearing (from ebay Germany) and opened the unit up.

P1020831

P1020832
rear view

 

 

P1020841 P1020842 P1020843 P1020844 P1020845 P1020846 P1020847 P1020848 P1020849 P1020850

 

 

without case

 

 

 

 

 

 

First I removed the siderails and the frontplate knobs

 

 

 

Then I removed the face plate all together.

 

 

 

 

 

Get the meters and the controls out

 

 

 

 

Remove old and insert new bulb

 

 

 

 

Testing….yes! Part 1 is done!

 

 

 

 

Remove the bits around the heads.
Also a good time to do some cleaning.

 

 

 

 

Remove the old roller bearing

 

 

 

 

And put the new one in place. Part 2 done!

 

 

 

 

 

Also put the unit on 240 Volts

P1020834new

 

 

 

 

This is the test point where the tape sensor should be measured

 

 

 

 

And this is the potentiometer that should be adjusted.

 

 

P1020852

 

 

All done! There is light in the dark!

(view count: 2389)